Hay & Forage Forum banner
21 - 26 of 26 Posts

·
Registered
Joined
·
545 Posts
Discussion Starter · #22 ·
Well spent some time looking over things again on this thing, and had been using the tractor some the last few weeks spreading manure. Monitor got to where it hardly worked. Might be fine for a little while then totally dead for several hours.

I was nervous about buying a new non-returnable $1700 monitor until I was sure. So I took it out and went and hooked it up on a buddy's 7400 and it was still dead.

Ordered a new monitor and put it in this morning. So far so good. Sure will be nice seeing what's going on again : )
 

·
Registered
Joined
·
545 Posts
Discussion Starter · #24 ·
Yeah it's a lot for sure. But I couldn't stand it not working, at least not once it pretty much totally quit. Had a guy I know who is a Deere mechanic look at it and he thought the dash was shot. But I'm still glad I double checked on the other tractor first since they wouldn't return it once it left the parts counter since it was an electronic part. That is the only thing major I've had to spend on that tractor so far so I'm not complaining too much.
 

·
Super Moderator
Joined
·
15,814 Posts
And in some ways, finding out for sure that it was the monitor could save you a tremendous amount of grief and possibly money. Sometimes a short or a intermittent short is the hardest thing in the world to locate. At least the problem is solved and your working life will be better and normalized again.

Regards, Mike
 

·
Registered
Joined
·
1 Posts
I'll be taking my 7200 dash apart in a few weeks and I'll let you know what I find.....mines the same way, except when it does work, you can barely see it.....I'm guessing cold solder connections at the board but idk
I'll be taking my 7200 dash apart in a few weeks and I'll let you know what I find.....mines the same way, except when it does work, you can barely see it.....I'm guessing cold solder connections at the board but idk
Hi was reading this old thread and noticed you had the same problem with 7200 dash and would really like to know how you fixed it. Thank you
 
21 - 26 of 26 Posts
Top