Hay & Forage Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Aside from my 5320 issues, I also have a 5075E cab that would sometimes act like the battery was weak when I would crank it. Now sometimes when I crank it it's started making a fast clicking noise and then a grinding sound like when you grind a gear. It only does it some of the time. I will turn the key off and re-crank and it does fine. Any thoughts on why it's doing this. The battery was bought in 2018 or 2019, so it's not old. And the tractor doesn't act up every time you crank it, only some of the time. I'm not wanting to have to take it to the dealer either if I can fix it myself. All thoughts on the matter are greatly appreciated. Not a good time of the year to have a tractor out of service when you have hay to cut and bale.
 

·
Member
Joined
·
10,015 Posts
First place to start would be the battery terminals and connections leading up to the battery. I would clean and inspect throughly. Then check wires leading to the starter to make sure they are grunt tight.
 

·
Registered
Joined
·
5,027 Posts
I agree with Dawg to check/clean/tighten all 4 battery cable connections. If starting problems still persist then I'd suggest to check/replace starter relay(RE23472).
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
Done with hay for a few weeks, so I will definitely take a look at these this weekend. Hopefully it'll fix my problem. Can't have this tractor out of use, cause my wife likes the AC and radio too much.
 
1 - 5 of 5 Posts
Top