replacing stolen bale monitor on a new holland br 780a baler - Machinery - HayTalk - Hay & Forage Community

Jump to content




Photo
- - - - -

replacing stolen bale monitor on a new holland br 780a baler


  • Please log in to reply
2 replies to this topic

#1 hardluckcowboy

hardluckcowboy

    Newbie

  • Members
  • 1 posts
  • Locationalberta

Posted 19 July 2020 - 10:50 PM

Hi Guys  I am looking at possibly purchasing a used BR780a baler privately and am looking for some input/advice. From what I have been told by seller the baler has aprox 6500 bales on it and was gone through and checked and any necessary repairs done by his local NH dealer when he purchased it not that many bales ago.  In the middle of haying last year his pickup truck was stolen and never recovered,with the baler monitor in it. Long story but he ended up buying another baler to finish haying and has decided to sell this one this year. He purchased a used replacement monitor from a ag equip recycler (from a burnt baler) but has never hooked it up yet.  I was hoping to find out what if anything has to be done to match unit to baler. Seller thinks it has to be set up by a new holland dealer.  Hoping some of you guys with experience could help me out.  

       Also just wanted to say hats of to guys like Mike10 and thanks so much for helping and sharing your knowledge. It has been a real lifesaver when working on things like autowrap and sledge rolls on my old NH660 etc.



#2 mike10

mike10

    Senior Member

  • Members
  • 2294 posts
  • LocationSouthern Indiana

Posted 20 July 2020 - 07:09 AM

You should not have to do anything.  All the information is stored in the baler controller



#3 mlappin

mlappin

    Hay Master and Moderator

  • Moderators
  • 10865 posts
  • LocationNorth Liberty, Northern Indiana

Posted 20 July 2020 - 04:16 PM

What Mike said. I was having what I thought was monitor issues, borrowed the neighbors monitor and ran it on my baler with no issues. I’ve also rented a baler with a crop cutter as mine doesn’t have one, just simply plugged the rental baler into my harness and again no issues. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

× Sponsors